User Ingestion Delay
Incident Report for BetterCloud
Monitoring
We have addressed the issue and have seen improvement in the delays. We will continue to monitor and make additional improvements as needed. If you have any questions, please contact our Support Team.
Posted Sep 16, 2024 - 14:02 EDT
Investigating
We have identified and are investigating an issue resulting in some delays related to user syncs for a small subset of customers. We apologize for the inconvenience this issue is causing and will post updates as we know more. Please reach out to our support team by emailing support@bettercloud.com if you have any questions.
Posted Sep 13, 2024 - 14:37 EDT
This incident affects: BetterCloud (Alerts, Directory, Workflows).