File Ingestion Delay
Incident Report for BetterCloud
Monitoring
We have addressed the issue causing delays ingesting Files for a subset of customers. We will continue to monitor and make additional improvements as needed. If you have any questions, please contact our Support Team.
Posted Sep 17, 2024 - 16:40 EDT
Investigating
We are currently investigating an issue causing delays ingesting Files for a subset of customers. Affected customers may experience delays in Files appearing/updating in the UI, as well as delays triggering File based Automations. If you have any questions, feel free to reach out our Support Team by emailing
Posted Sep 10, 2024 - 09:46 EDT
This incident affects: BetterCloud (Alerts, Files, Data Protection).