Ingestion delays

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 17:04 EST

Identified

We have identified and are investigating an issue resulting in some delays related to syncs for a subset of customers. We apologize for the inconvenience this issue is causing, and will post updates as we know more. Please reach out to our support team by emailing support@bettercloud.com if you have any questions.
Posted Nov 03, 2025 - 13:40 EST
This incident affected: User Automation (Directory, Files).